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Übung 1: Installation + Test von Eclipse 
 
 
Führen Sie die Installation der Entwicklungsumgebung Eclipse durch gemäss 
Dokument  "InstallationTest.Eclipse.7.0.pdf" auf der CD  im Directory “Eclipse”. 
 
Hinweise: 
 
Die Beschreibung "InstallationTest.Eclipse.7.0.pdf" ist ausgelegt für die Installation 
auf einem persönlichen Rechner. 
 
Ihre persönliche Daten werden an der HSR als Drive U: ge'mapped. 
 
Installieren Sie Eclipse im Directory U:\test  
(anstelle von C:\Program Files; das Directory test muss dabei explizit angelegt 
werden). 
 
Beim Workspace-Launcher soll als Workspace (für die Meta-Daten von Eclipse) das 
Directory U:\Eclipse festgelegt werden. 
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Übung 2: Hello World 
 
Erzeugen Sie ein neues Projekt mit dem Namen U02_HelloWorld . 
Selektieren Sie dann den neuen 'Ordner' U02_HelloWorld im Package Explorer und 
wählen Sie Menü:File>New>Class .  
 
Damit wird eine neue sog. Klasse erzeugt. 
 
 
 
 
 
1. Wählen Sie als Namen HelloWorld: 
 
 
 
 
 
2. Es soll ein 'main()' erzeugt werden: 
 
 
 
 
 
3. Finish. 
 
 
 
Im Package Explorer erscheint ein neues File: HelloWorld.java 
Das ist das Source-File indem das Programm erstellt wird. 
 
Mit System.out.println() kann auf die Konsole geschrieben werden. 
Für ein "Hello World" erweitern Sie das Programm wie folgt: 
 
public class HelloWorld { 
 
    public static void main(String[] args) { 
        System.out.println("Hello World."); 
    } 
} 
 
 
Bringen Sie das Programm zur Ausführung. 
 
 
Verifizieren Sie die Ausgabe von println() auf der Console. 
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Übung 3: Standard-Eingabe 
 
Um Eingaben von der Tastatur einlesen zu können muss eine Applikation die sog. 
Standard-Eingabe (stdin) lesen. 
 
Das folgende Beispiel-Programm illustriert das Einlesen von Strings und Zahlen 
(ganze Zahlen (int) und Gleitkommazahlen (double)): 
 
import java.util.Scanner; 
 
public class StdIn {   
 
    public static void main(String[] args) { 
         
        // Vergindung zur Standard-Eingabe resp.zum Keyboard: 
        Scanner eingabe = new Scanner(System.in);   
 
        System.out.print("Ein String : "); 
        // Einlesen eines Strings von der Standard-Eingabe: 
        String str = eingabe.next();            
        System.out.println("String = " + str); 
       
        System.out.print("Ganze Zahl : "); 
        // Einlesen einer Zahl von der Standard-Eingabe als Ganzahl  
        // vom Typ 'int': 
        int i = eingabe.nextInt();             
        System.out.println("Zahl = " + i); 
     
        System.out.print("Gleikomma-Zahl : "); 
        // Einlesen einer Zahl von der Standard-Eingabe als Gleitkommazahl  
        // vom Typ 'double': 
        double d = eingabe.nextDouble();   
        System.out.println("Zahl = " + d); 
         
        System.out.println("ENDE."); 
         
    } 
} 
 
Erzeugen Sie in Eclipse ein neues Projekt mit dem Namen U03_StdIn und 
programmieren Sie obiges Programm. 
 
Hinweise:  
Machen Sie bewusst Syntax-Fehler und schauen Sie, wie sich Eclipse verhält. 
 
Bei der Ausführung sind die Tastatur-Eingabe im Tab Console vorzunehmen: 
 
 
 
 
 
 
 
 
 
Beobachten Sie was passiert, wenn Sie anstelle einer Zahl eine Zeichenkette 
eingeben, z.B. "Hallo". 
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Übung 4: Rechnen 
 
Erstellen Sie ein Programm, das zuerst zwei ganze Zahlen von der Konsole einliest 
und von diesen dann die Summe, die Differenz, das Produkt, den Quotienten und 
den Rest der Ganzzahldivision berechnet und ausgibt, sowie daraufhin das selbe für 
zwei Gleitkommazahlen wiederholt. 
 
(Hinweis: die entsprechenden Operatoren: +, -, *, / ) 
 
Nachfolgend die ist ein Session-Log dargestellt, dass zeigt wie sich das Programm 
verhalten soll: 
 
 

1. ganze Zahl = 8 
2. ganze Zahl = 3 
Summe     = 11 
Differenz = 5 
Produkt   = 24 
Quotient  = 2 
Rest      = 2 
 
1. Gleitkommazahl = 8 
2. Gleitkommazahl = 3.1 
Summe     = 11.1 
Differenz = 4.9 
Produkt   = 24.8 
Quotient  = 2.5806451612903225 
Rest      = 1.7999999999999998 
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Übung 5: Zeit-Umrechnung 
 
Erstellen Sie ein Programm, das eine Anzahl von Sekunden einliest und diese dann 
in die entsprechende Anzahl von Tagen, Stunden, Minuten und Sekunden 
umrechnet. 
 
Das Programm soll sich wie im nachfolgenden Beispiel verhalten. 
Programmabbruch bei Sekunden < 0. 
 
Beispiel: 
 
Sekunden   : 145 
  Tage     = 0 
  Stunden  = 0 
  Minuten  = 2 
  Sekunden = 25 
 
Sekunden   : 100000 
  Tage     = 1 
  Stunden  = 3 
  Minuten  = 46 
  Sekunden = 40 
 
Sekunden   : -1 
Good Bye. 
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Übung 6: Potenz-Rechnung 
 
Erstellen Sie ein Programm, dass die Potenz zu einer beliebigen Basis und Exponent 
berechnet. 
 
Das Programm soll sich wie im nachfolgenden Beispiel verhalten. 
Programmabbruch bei einer Basis < 0. 
 
Beispiel: 
 
Basis:   2 
Exonent: 3 
2^3 = 8 
 
Basis:   2 
Exonent: 20 
2^20 = 1048576 
 
Basis:   10 
Exonent: 3 
10^4 = 1000 
 
Basis:   -1 
Good Bye. 
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Übung 7: Eclipse - 'New Project'  und nachfolgend  
                                 hineinkopieren von bestehenden Files 
 
 
Zweck:  
 
Wir wollen ein neues Projekt erstellen und bestehende Java-Files darin 
hineinkopieren. 
Die Orginal-Files sollen dabei unberührt bleiben. 
 
 
Durchführung: 
Erstellen Sie in Eclipse ein Projekt mit dem Namen "U03_StdIn_ML1"  
(ML: Musterlösung). 
 
Kopieren Sie die Musterlösung der "Übung 3: Standard-Eingabe" von  
www.letsch-informatik.ch: Download>MAS>2_TrainingskursJava>u03_StdIn  in das 
neu erzeugte Projekt-Directory von Eclipse (befindet sich im Workspace unter 
U:\Eclipse). 
Achtung: je nach Web-Browser wird dem Filename eine Extension “.htm” oder “.html” 
hinzugefügt. In diesem Fall den Filename von Hand wieder auf StdIn.java 
anpassen. 
 
In Eclipse wird das neue File im Package Explorer noch nicht sichtbar! 
 
Selektieren Sie nun im Package Explorer den Ordner U03_StdIn_ML1. 
Dann im Context-Menü (rechte Maustaste)  des obigen Ordners den Refresh wählen 
(oder einfach Funktionstaste F5). 
Jetzt sollte das File sichtbar werden (im default package). 
 
Bringen Sie das Programm zur Ausführung. 
 
 
Hinweise: 
• Sie können so auch beliebig viele Files (auch mit Sub-Directories) auf einmal in 

ein Projekt integrieren. 
• man kann nach dem 'Copy' im Explorer den 'Paste' auch direkt im Package 

Explorer von Eclipse durchführen (somit kann man auf den Refresh verzichten ;-) 
 
 



HSR / MAS SE 2009 Grundlagen der Progammierung mit Java Thomas Letsch 
   

   
 
17.03.09 Copyright © 2009 by Letsch Informatik @ CH-8636 Wald 8 

 

Übung 8: Eclipse - 'New Project'  und nachfolgender  
                                 Import von bestehenden Files 
 
 
 
Zweck:  
 
Wir wollen ein neues Projekt erstellen und bestehende Java-Files darin 'importieren' 
(d.h. ins Projekt hineinkopieren). 
Die Orginal-Files sollen dabei unberührt bleiben. 
 
 
 
Durchführung: 
 
Kopieren Sie die komplette Musterlösung (java- und pdf-File) von 
www.letsch-informatik.ch>Download>MAS>2_TrainingskursJava>u03_StdIn nach 
z.B. C:\TEMP\u03_StdIn. 
 
Erstellen Sie in Eclipse ein Projekt mit dem Namen "U03_StdIn_ML2"  
(ML: Musterlösung). 
 
Importieren Sie in dieses Projekt obige Musterlösung mit:  
- im Package Explorer das Projekt öffnen und den Folder ‘src’ selektieren 
- Menü: File > Import... > General > File System  
 - From directory:  C:\TEMP\u03_StdIn 
 - Selektion:           Stdin.java   (  CheckBox) 

    Stdin.java.pdf  (  CheckBox) 
- Finish 
 
Verifizieren Sie auf dem Disk, ob die Files jetzt auch wirklich dort vorhanden sind wo 
Sie sie erwartet haben (im Verzeichnis src )! 
 
Bringen Sie das Programm zur Ausführung. 
 
Vergegenwärtigen Sie sich den Unterschied zur letzten Übung.
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Übung 9: Eclipse - 'New Project' auf bestehenden Files 
 
 
Zweck:  
 
Wir wollen ein neues Projekt erstellen auf bereits bestehenden Java-Files. 
D.h. wir arbeiten danach mit diesen Files. 
 
 
Durchführung: 
 
Kopieren Sie die komplette Musterlösung (java- und pdf-File) von 
www.letsch-informatik.ch>Download>MAS>2_TrainingskursJava>u03_StdIn zu sich 
irgendwo auf den Home-Drive (z.B. U:\TrainingsKursJava\u03_StdIn). 
 
Hinweis:  Projekte nicht ‘von Hand’ im Workspace (U:\Eclipse) anlegen! 
   die Verwaltung des Workspace ist für Eclipse reserviert ;-) 
 
Erstellen Sie in Eclipse ein Projekt mit dem Namen "U03_StdIn_ML3". 
- Contents:  

Create project from existing  source: `enable`   
(Create new project in workspace: `disable`    (automatisch) ) 
Directory:   ... Browse ...    U:\TrainingsKursJava\u03_StdIn 
 

- Finish 
 
Beachten Sie die beiden neuen Files .project und .classpath im Projekt-Directory 
u03_StdIn ! 
Diese enthalten für Eclipse entsprechende Meta-Informationen über das Projekt.  
Es sind XML-Files und können mit einem Text-Editor angesehen werden. 
 
Bringen Sie das Programm zur Ausführung. 
 
Vergegenwärtigen Sie sich den Unterschied zu den letzten Übungen.
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Übung 10: Eclipse - Import eines bestehenden Eclipse-
Projektes 
 
Zweck: 
Wir wollen ein bestehendes Eclipse-Projekt (z.B. vom Büro oder Zuhause) in den 
Workspace importieren. 
 
Durchführung: 
1. Bestehendes Eclipse-Project komplett, d.h. insbesonders incl. der beiden Files 
.classpath und .project, an den Zielort kopieren (z.B. mit MS-Explorer oder mit 
WinZip dorthin auspacken). 
 
2. Dann in Eclipse: File > Import... > General > Existing Projects into Workspace 
 
Beachten Sie, dass nach dem 
Setzten von 'Select root directory:' 
das Projekt unter  'Projects’ angezeigt 
wird. Dabei wird der Projekt-Name 
vom importieren Projekt übernommen 
(dieser muss nicht identisch sein wie 
das Directory, in welchem sich das 
Projekt befindet!). 
 
 
 
 
 
 
 
 
 
Konkret:  
 
Laden Sie die Musterlösung der 
Übung 4 "Rechnen" runter: 
www.letschinformatik.ch>Download>MAS>2_TrainingskursJava>u04_Rechnen> 
u04_Rechnen.zip 
 
Entpacken Sie das ZIP-File, z.B. nach U:\TrainingsKursJava\u04_Rechnen 
(Hinweis: nicht in den Workspace U:\Eclipse!) 
 
Importieren Sie dieses Projekt gemäss obigen Angaben in Eclipse. 
 
ACHTUNG: 
- mit File > Import... > Existing Projects into Workspace 
- und NICHT mit File > Import... > Zip file !!! 
 
Verifizieren Sie, dass das File geändert, kompiliert und ausgeführt werden kann. 
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Übung 11: Cast 
 
Da Java eine typensichere Sprache ist, sind Zuweisungen von ungleichen 
Datentyp nicht erlaubt. 
Dennoch kann z.B. eine Zuweisung eines double in einen int erzwungen werden 
unter Zuhilfenahme des sog. Cast-Operators:  (type) 
Dabei wird mit type der Ziel-Datentyp spezifiziert. 
 
Beispiel:   

 
double franken = 1.25; 
double rappenDouble = franken * 100; 
int rappenInt = (int) rappenDouble; 

 
Erstellen Sie ein Programm, dass vom Benutzer einen Franken-Betrag erfragt und 
dann diesen in Rappen umrechnet und auf die Konsole ausgibt. 
Beispiel: 
 

Geben Sie einen Franken-Betrag an : 1.25 
Umgerechnet in Rappen             = 125 

 
 
 

Übung 12: Überlauf 
 

Definieren Sie eine Variable vom Type byte und initialisieren Sie diese mit 0. 
Inkrementieren Sie daraufhin 300 mal diese byte-Variable um 1 und geben Sie das 
Resultat jeweils auf die Konsole aus. 
Was stellen Sie fest ? 
 
Hinweis: 
Eine Zahl kann mit dem sog. Inkrement-Operator ++ um den Wert 1 inkrementiert 
werden. 
Beispiel:  meineZahl++; 

 

Übung 13: Fakultät 
 

Erstellen Sie ein Programm, dass die Fakultät berechnet. 
Die Fakultät für eine Zahl n ist definiert als:  1 * 2 * 3 * .. n 
Die Fakultät von 0 ist 1 und für negative Zahlen nicht bestimmt. 
Beispiel: Fakultät von 4 ist  1 * 2 * 3 * 4  24 
Schreiben Sie ein entsprechendes Programm, welches die Zahl n von der Konsole 
einliest, die Fakultät berechnet und das Resultat auf die Konsole ausgibt. 
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Übung 14: Quersumme 
 

Erstellen Sie ein Programm, dass die Quersumme berechnet. 
Die Quersumme ist definiert als die Summe der einzelnen Ziffern einer Dezimalzahl. 
Beispiel:  1234 = 1 + 2 + 3 + 4  10 
Schreiben Sie ein entsprechendes Programm. 
 
Hinweise:  
Verwenden Sie dazu die Ganzahl-Division (/)  und den Modulo-Operator (%). 
 
 
 

Übung 15: Zahlen raten 
 

Ein Spiel-Programm: das Programm ermittelt eine Zufallszahl zwischen 0 und 100 
und der Spieler muss diese Zahl herausfinden. 
 
Ablauf: 
Das Programm bestimmt eine Zufallszahl mit:  

int zufallsZahl = (int) (101 * Math.random()); 
Daraufhin wird der Benutzer nach einer Zahl abgefragt. 
Diese Zahl wird mit der Zufallszahl verglichen und wenn sie falsch ist, wird dem 
Benutzer mitgeteilt, ob die eingegebene Zahl zu klein oder zu gross ist. 
Dies wird wiederholt bis die richtige Zahl gefunden wurde. 
Am Ende gibt das Programm bekannt, wieviele Versuche nötig waren. 
 
Überlegen Sie sich im weiteren, wieviele Versuche maximal nötig sind um die richtige 
Zahl zu finden. 
 
 
 

Übung 16: Primzahlen 
 

Erstellen Sie ein Programm, dass alle Primzahlen in einem definierbaren Bereich 
sucht. 
 
Beispiel: 
 

Geben Sie den Bereich ein. 
Untere Grenze: 2 
Obere Grenze:  30 
Primzahlen:    2 3 5 7 11 13 17 19 23 29  

 
Hinweis: 
Primzahlen sind natürliche Zahlen (ganze Zahlen > 0), die nur durch sich selbst und 
1 ohne Rest teilbar sind (wobei 1 keine Primzahl ist).
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Übung 17: Arrays 
 

Ein int-Array soll mit den Zahlen 1, 2, 3, 4, 5 und 6 initialisiert werden. 
Geben Sie zur Verifiaktion den Inhalt des Array auf die Konsole aus. 
 
Dann sollen von der Konsole sechs int-Werte eingelesen werden und der Reihe 
nach im Array gespeichert werden. 
Geben Sie zur Verifiaktion wieder den Inhalt des Array auf die Konsole aus. 
 
Vertauschen Sie sodann alle Werte innerhalb des Arrays (das erste wird zum letzen, 
das zweite zum zweitletzten, etc.). 
Geben Sie zur Verifiaktion wieder den Inhalt des Array auf die Konsole aus. 
 
 
Beispiel: 

 
Ausgabe des Arrays: 
1 2 3 4 5 6  
Einlesen des Arrays: 
Zahl fuer Index [0] : 11 
Zahl fuer Index [1] : 22 
Zahl fuer Index [2] : 33 
Zahl fuer Index [3] : 44 
Zahl fuer Index [4] : 55 
Zahl fuer Index [5] : 66 
Ausgabe des Arrays: 
11 22 33 44 55 66  
Ausgabe des gedrehten Arrays: 
66 55 44 33 22 11  
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Übung 18: String-Längen-Sortierung 
 

Schreiben Sie ein Programm, welches von der Konsole sequentiell maximal fünf 
Strings einliest oder bis der String "ENDE" eingegeben wird. 
 
Die Strings sollen in einem String-Array gespeichert werden. 
 
Dann sollen die Strings innerhalb des Arrays aufgrund ihrer Länge sortiert werden. 
Kürzester String zuerst. 
 
Am Schluss soll der Inhalt des sortierten Arrays auf die Konsole ausgegeben werden. 
 
 
Beispiele: 

 
Neuer String: Hans 
Neuer String: Katharina 
Neuer String: Joe 
Neuer String: Claudia 
Neuer String: James 
 
Ausgabe: 
Joe 
Hans 
James 
Claudia 
Katharina 

 
 
Oder: 
 
 

Neuer String: Claudia 
Neuer String: Hans 
Neuer String: Joe 
Neuer String: ENDE 
 
Ausgabe: 
Joe 
Hans 
Claudia 
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Übung 19: Library-API-Dokumentation 
 
In Java ist ein Mechanismus für die Programm-Dokumentation eingebaut Javadoc 
Dabei wird aus speziellen Programm-Kommentaren eine HTML-Dokumentation 
generiert. 
Die komplette Laufzeit-Bibliothek (Runtime-Library), die mit der Java 2 Platform 
Standard Edition (J2SE) mitkommt, ist so dokumentiert. 
Dazu muss diese jeweils speziell heruntergeladen werden, z.B.  für  
jdk-6-doc.zip für jdk1.6.0_06 und im Installations-Directory des J2SE 
ausgepackt werden   Sub-Directory: jdk1.6.0_06/docs . 
Wenn diese Dokumentation vorhanden ist, kann diese in Eclipse eingebunden 
werden, sodass aus dem Editor ein direkter Zugriff darauf möglich wird. 
Hinweis: für JDK 1.6 ist das entsprechende ZIP-File (jdk-6-doc.zip ) auf der CD. 
 
Einbinden der Library-API-Dokumentation in Eclipse (API: Application Programming 
Interface): 
 

• Menü : Window > Preferences > Java > Installed JREs  
• Die aktuelle JRE anwählen, dann EDIT... 
• Die Bibliothek rt.jar expandieren. 

o Den Eintrag “Javadoc location:” editieren (Doppel-Klick): 
o “Javadoc location path:” auf das entsprechende Directory einstellen, 

z.B.: file:/C:/Program Files/Java/jdk1.6.0_06/docs/api/ 
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Daraufhin hat man von allen Elementen, welche in der Laufzeit-Bibliothek mit einem 
Javadoc-Kommentar versehen sind, direkten Zugriff darauf. 
 
Versuchen Sie z.B. bei der Übung 3 “Standard Eingabe”  direkt nach dem main() 
den Cursor auf den String "Scanner" zu positionieren.  
Es werden als Tool-Tip die ersten Zeilen des Javadoc-Kommentars von Scanner 
dargestellt. 
 

 
Wenn man die Funktionstaste F2 drückt, wird der ganze Kommentar als Tool-Tip mit 
Scrollbars dargestellt. 
 
Setzt man den Cursor auf das Wort “Scanner” und drückt man SHIFT-F2 wird ein 
HTML-Browser mit obigem Kommentar gestartet (kann u.U. einen Moment dauern).  
 

 
 
Der konkret benutzte HTML-Browser wird unter Menü:Window > Preferences > Help 
festgelegt. 
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Übung 20: Anbindung der Library-Sourcen  
 
Die Sourcen der gesamten Laufzeit-Bibliothek sind ebenfalls verfügbar. 
Diese sind je nach J2SE-Version separat zu beschaffen und einzubinden. 
Das File heisst jeweils src.zip und ist normalerweise im Root-Directory der JDK-
Installation. 
Die eigentliche Laufzeit-Bibliothek (Runtime-Library) ist im File rt.jar enthalten.  
Diesem File können nun die Sourcen attach'ed werden. 
 
Die Einbindung erfolgt analog zur vorherigen Einbindung der Javadoc: 
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Die Library-Sourcen können geöffnet werden, indem ein API-Element selektiert wird, 
und dann: 

• Context-Menü (rechte Maustaste)>Open Declaration 
oder 
• F3 
oder 
• CTRL+linke Maustaste 
 

 
 
 
 
Die Library-Sourcen sind auch mit dem Debugger  mittels Step Into (F5) sichtbar !! 
Verifizieren Sie das bei der Funktion println() bei der Übung 2 Hello World . 



HSR / MAS SE 2009 Grundlagen der Progammierung mit Java Thomas Letsch 
   

   
 
17.03.09 Copyright © 2009 by Letsch Informatik @ CH-8636 Wald 19 

 

Übung 21: String  
 

Schreiben Sie ein Programm, dass ein Satz auf einer Zeile von der Konsole einliest 
und dann den Satz wieder auf die Konsole ausgibt, aber dabei die Reihenfolge der 
Wörter vertauscht. 
 
Beispiel: 

- Eingabe: "heute regnet es" 

- Ausgabe: "es regnet heute" 
 
Die Klasse Scanner verfügt über nextLine() um eine ganze Zeile incl. sog. 
Whitespaces (Leerschläge, Tabulatoren, etc) einzulesen (analog  zu nextInt()für 
Integer). 
 
Verwenden Sie die Online-API-Dokumentation der Klasse 'String’  um geeignete 
Methoden (Funktionen) für die Lösung dieses Problems zu finden. 
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Übung 22: Vokabel-Trainer  
 
Schreiben Sie ein Programm, dass Sie beim Lernen von Vokabeln unterstützt. 
 
Hinweise:  
• Benutzen Sie für die Speicherung der Informationen einen zweidimensionalen 

Array von Strings. 
• die Klasse Scanner besitzt auch einen Konstruktor Scanner(String source). 

Bei diesem kann anstelle von System.in auch ein normaler String übergeben 
werden, um daraus z.B. mit nextInt() einen entsprechenden Integer zu 
erhalten. 

• Um aus einem String meineNummer einen entsprechenden int i zu 
erhalten: 
int i = Integer.parseInt(meineNummer); 

• Um aus einem int i  wieder einen entsprechenden String zu erhalten:  
String meineNummer = Integer.toString(i); 
 
 

Beispiel auf der Konsole (fett gedrucktes sind User-Eingaben): 
 

Geben Sie max. 10 zu übende Vokabeln ein. 
 
Format:    Frage-String:Antwort-String:nötige Anzahl richtiger Antworten 
Beispiel:  Baum:Tree:3 
Ende:      leerer String 
 
Begin der Eingabe: 
1. Vokabel: Baum:Tree:2 
2. Vokabel: See:Lake:1 
3. Vokabel:  
O.K.: Ende der Eingabe. 
 
Beginn des Trainings: 
 
Baum: Tree 
o.k :-) ; noch 1 
 
See: Lago 
NOK :-( ; noch 1 
 
Baum: Tree 
o.k :-) ; Fertig 
 
See: Lake 
o.k :-) ; Fertig 
 
Alle richtig, Gratulation! 
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Übung 23: Methoden I 
 
In der Übung 17 "Arrays" musste der Inhalt des Arrays mehrmals auf die Konsole 
ausgegeben werden. 
 
Erstellen Sie in jenem Programm eine Methode printArray(int[] pArray), 
welche diese Aufgabe übernimmt und benutzen Sie diese dann für die Ausgaben der 
Arrays auf die Konsole. 
 
 
 

Übung 24: Methoden II 
 
Erstellen Sie eine Methode, welche als Parameter drei Integer aufweist und die 
grösste der drei Zahlen bestimmt und sodann als return-Wert zurückgibt. 
Testen Sie die erstellte Methode. 
 
 
 

Übung 25: Zweidimensionales Array 
 
Erstellen Sie eine Methode, welche als Parameter die Grösse für eine Matrix erhält. 
Die Methode erzeugt sodann aufgrund des Parameters ein zweidimensionales  
int-Array und initialisiert die Elemente aufgrund der Position in der Matrix (siehe 
nachfolgendes Beispiel). 
Dann wird die Matrix auf die Konsole ausgegeben. 
Daraufhin wird die Matrix mit einer zweiten Methode transponiert (d.h. die Elemente 
werden um die Diagonale ann gespiegelt). 
Daraufhin wird die transponierte Matrix wieder ausgegeben. 
 
Hinweis: setzen Sie auch wieder die printArray()-Methode von Übung 23 ein. 
 
Session-Log: 
 

Matrix: 
11  12  13  14   
21  22  23  24   
31  32  33  34   
41  42  43  44   
 
Transponierte Matrix: 
11  21  31  41   
12  22  32  42   
13  23  33  43   
14  24  34  44   
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Übung 26: Container 
 

Erstellen Sie ein Programm, dass den Benutzer nach einer Zahl fragt. 
Dann werden gemäss dieser Zahl int-Arrays wie folgt erzeugt.  
Inhalt der Arrays: Nummer des Arrays nach dem Schema:   

x xx xxx xxxx ... wobei x = Nummer des Arrays [1..9] 
Diese werden der Reihe nach in einen Vector eingefügt. 
Am Ende werden die Arrays aus dem Vector ausgelesen und auf die Konsole 
ausgegeben. Verwenden Sie dazu die Methode printArray() aus der vorherigen 
Übung. 
 
Wenn eine Zahl eingegeben wird, die nicht zwischen 1 und 9 liegt, soll das 
Programm terminieren. 
 
 
Beispiel: 
 

Zahl: 7 
1  
2 22  
3 33 333  
4 44 444 4444  
5 55 555 5555 55555  
6 66 666 6666 66666 666666  
7 77 777 7777 77777 777777 7777777  
Zahl: -1 
ENDE. 
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Übung 27: Navigations-System 
 

Eine Firma, welche ein Navigations-System für die Schifffahrt gebaut hatte, ist 
konkurs gegangen. 
Dummerweise sind im Durcheinander auch die Sourcen der Programme 
verschwunden. 
 
Wir haben den Auftrag, ein neues, identisches System in Java zu entwickeln. 
Das alte System ist noch als Binary vorhanden: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Die neue Java-Applikation soll genau gleich aussehen und sich genau gleich 
verhalten wie das bestehende System. 
 
U.a. sollen die  Dimensionen als Konstanten definiert werden können.  
Beispiel: 
 
  final static int COLS = 30;  // Number of Columns 
  final static int ROWS = 10;  // Number of Rows 
 
Hinweise: 
Das bestehende Programm ist verfügbar unter:  
http://www.letsinfo.ch/download/MAS/2_TrainingskursJava/u27_NavigationsSystem 
als NavigationSystem.jar. 
 
Das Programm kann durch Doppelklick auf das File gestartet werden. 
Es muss aber java.exe (und nicht javaw.exe) für die Extension “.jar” konfiguriert sein 
(Disk Explorer>Tools>Folder Options...>File Types>Jar File>Change... auf z.B. 
C:\Program Files\Java\jdk1.5.0_04\bin\java.exe). 
 
Sonst aus der Kommando-Shell starten mit dem Kommando:  
java -jar NavigationSystem.jar 
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Ein paar Tips: 
 
Es macht Sinn, den ganzen Inhalt des Bildschirmes in einem char-Array 
aufzubereiten und zu bewirtschaften (char[][] carr;) und dann mit einer 
Schleife auf den Monitor auszugeben. 
 
Um Arrays zu kopieren: System.arraycopy() 
 
Um von einem String zum entsprechenden char-Array zu kommen: 
String.toCharArray() 
 
Um von zwei Zahlen die grössere oder kleinere zu erhalten: Math.max() resp. 
Math.min() 
 
Phytagoras:  
Math.sqrt(Math.pow(y-newYPos, 2) + Math.pow(x-newXPos, 2)); 
 
Um von einem int zum entsprechenden String zu kommen:   
Integer.toString(i) 
 
Um eine bestimmte Anzahl von Millisekunden (z.B. 300 Millisekunden) zu warten: 
try { Thread.sleep(300);} catch (InterruptedException e) {} 
 
 
Globale Konstanten werden direkt nach der Klassen-Deklaration und vor der ersten 
Funktion definiert (z.B. final static int COLS = 30;)  
 
“Hupen” ;-) :  java.awt.Toolkit.getDefaultToolkit().beep(); 
 
Der Routing-Algorithmus muss nicht genau gleich funktionieren wie bei der alten 
Applikation (der Weg kann unterschiedlich sein. Das Ziel muss einfach erreicht 
werden). 
 
 
 
 
 
 
 
                        Viel Spass ;-) 
 
 


